Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

PaulL Offline
#1 Posted : Thursday, February 10, 2011 9:44:19 PM(UTC)
PaulL

Rank: Newbie

Groups: Registered
Joined: 2/10/2011(UTC)
Posts: 1

I hope that someone can help me. We just purchased a Create and are trying to use it for the first time. When I pushed the power on button, the machine lights up some keys on the keyboard and makes some clicking sounds near the blade assembly for an instant, then seems to go off, and soon repeats trying to turn on for an instant, go off, again and again until I hit the power on button again. Oddly (to me at least), the transformer unit on the power cord displays a solid green light prior to turning on the Create, but then goes out during the periods the Create is cycling itself between the on state described above and an off state. At no point does the screen power on. The Create does this both when a cartridge is loaded as well as when no cartridge is loaded. I've tried depressing the red reset button both when the power is off and when it is cycling between an on and off state. I've followed the suggestions as well for turning the dials to their lowest settings and moving them between their lowest and highest settings, all to no avail. Any suggestions?

A google search of this repeated "blinking" and "clicking" problem for the Create (and maybe other Cricuts) seems to suggest that others have had this problem as well, particularly with new Cricuts, but I haven't been able to find a suitable solution. The recommendations for using the red reset button do not seem to be effective since the instrument never really gets fully powered on.

So far, our experience with our Cricut has been regretful in not being able to use it. So, is this a common problem, and is there a simple solution? Thanks.
sweetpea1030 Offline
#2 Posted : Thursday, February 10, 2011 10:32:37 PM(UTC)
sweetpea1030

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 2/22/2009(UTC)
Posts: 3,495
Location: Earth

Thanks: 3010 times
Was thanked: 1604 time(s) in 1019 post(s)
Have you gone through the updating the firmware? You can do it through design studio or the gypsy or manually. With DS you go to help and choose update firmware. Then follow the instructions. With gypsy, power on and press the silver button one of your choices will be update firmware, choose it and follow directions. It can take 5 to 10 minutes to complete.

If that doesn't work or you don't have design studio or a gypsy, then you'll need to contact PC's customer service at 1-877-727-4288.

I'm not sure how you would update firmware without gypsy or design studio. I'll post if I find out or hopefully someone more knowledge than I have will answer.

Edited by user Thursday, February 10, 2011 10:56:09 PM(UTC)  | Reason: Not specified

sweetpea1030 Offline
#3 Posted : Friday, February 11, 2011 8:56:44 PM(UTC)
sweetpea1030

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 2/22/2009(UTC)
Posts: 3,495
Location: Earth

Thanks: 3010 times
Was thanked: 1604 time(s) in 1019 post(s)
I forgot to mention if you don't have a copy of Design Studio, you can download a trial copy of it from Cricut.com.HTH
Confused
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.370 seconds.
nebo-cricut-03