Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

maryeblakef77ac78e Offline
#1 Posted : Sunday, January 26, 2014 8:02:12 AM(UTC)
maryeblakef77ac78e

Rank: Newbie

Groups: Registered
Joined: 1/26/2014(UTC)
Posts: 1

I was cutting things out and then it just stopped.. I thought it was the blade so went and got another one and replaced it and nothing. it works up to the cutting it was going thought the whole thing just not cutting so we replaced the housing and now it don't even move. yes it turns on etc. just doesn't cut and not it don't even try to..

anyone else have this problem and if so is there a way to fix it?
Coah'sNana Offline
#2 Posted : Sunday, January 26, 2014 6:11:18 PM(UTC)
Coah'sNana

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 2/19/2011(UTC)
Posts: 6,664
Virgin Islands (U.S.)
Location: 'Almost Heaven' West Virginia

Thanks: 16704 times
Was thanked: 13219 time(s) in 3709 post(s)
You could try resetting it. Scrapalette has the reset procedure on her blog under Cricut help. If that doesn't work, you should contact support for additional troubleshooting.

http://scrapalette.blogspot.com/
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.287 seconds.
nebo-cricut-01