Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

ambersmdb34b49d Offline
#1 Posted : Thursday, June 13, 2013 9:27:26 PM(UTC)
ambersmdb34b49d

Rank: Newbie

Groups: Registered
Joined: 6/13/2013(UTC)
Posts: 1

Hi, my firmware is 1.0 on my Cricut Expression. I've tried 4 times through Craft Room to update to the latest version (2.34?) and it stops at the 3rd step when I am asked to power on my Cricut in the update mode (holding stop button) EVERY time. It won't proceed past this point. What do I do?
Narelle Offline
#2 Posted : Thursday, June 13, 2013 10:22:10 PM(UTC)
Narelle

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 9/26/2006(UTC)
Posts: 10,670
Australia
Location: Brisbane, Australia

Thanks: 1970 times
Was thanked: 7577 time(s) in 3540 post(s)
You need to get the expression to 2.43. You might want to try using the trial version of Design Studio to get it to 2.34. Then CCR to get it from 2.34 to 2.43.

Here's the link to download DS. (Download the Program Update). http://www.cricut.com/home/support/CDS

Once you have that installed go to the Help menu and select Update Cricut firmware. Make sure you select the Expression as the machine to be updated.

You'll probably have to do two passes of the update. Make sure you turn your Expression off before you start the second pass.

(DS doesn't work with Macs so fingers crossed you don't have one of those.)
c21kims65498a29 Offline
#3 Posted : Saturday, June 15, 2013 12:40:04 PM(UTC)
c21kims65498a29

Rank: Newbie

Groups: Registered
Joined: 6/15/2013(UTC)
Posts: 1

Cursing My firmware update has been stuck at 2% for an hour! Since it says stopping the process may cause my Cricut to no longer work properly, I'm afraid to end it...what do I do?
skyinva54 Offline
#4 Posted : Saturday, June 15, 2013 3:04:41 PM(UTC)
skyinva54

Rank: Newbie

Groups: Registered
Joined: 2/19/2012(UTC)
Posts: 6
United States

Thanks: 1 times
Was thanked: 3 time(s) in 3 post(s)
The same thing happened to me. If I wasn't getting the CCRBridge.exe error message, when it tried to update the firmware it just got stuck and never went anywhere. I just clicked it off and it didn't affect my Expression. My Cricut still has firmware version V2.32. I'm tired of dealing with this and will just go back to basic cutting with it.

I have several cartridges and have had my Cricut for over 4 years, but when I started reading about the Silhouette Cameo early last year, I was very enthusiastic about it. My kids got it for me for my birthday Feb. 2012. I love it. I had a coupon and upgraded to the Designer Edition for $25 a few months ago. I love their library where you can pick shapes you want, not have to take whatever is on a cartridge. Don't get me wrong, I just bought 3 more Cricut cartridges in the past couple of months and will probably buy more because the Cricut can cut through thicker materials than the Cameo, but since the Silhouette is so much more user friendly, I'll probably be using it more for basic and delicate paperwork, vinyl cutting, and fabric appliques, and save the Expression for chipboard and heavier materials.

One thing: I've heard many people, especially Silhouette devotees, say that the Cameo cuts much more intricate cuts than the Cricut and that the Cricut tends to tear the cuts more. I've never had that happen with my Expression. It cuts intricate cuts down to 1/4" and I also prefer the Cricut mats to Silhouette's.

I just wish this Craft Room mess could get cleared up because I surely would like to do more with my Expression. It is a heavier and sturdier looking machine next to my Cameo and looks like it could hold up longer. I guess time will tell.
 1 user thanked skyinva54 for this useful post.
karenquigs629740b0d on 9/26/2013(UTC)
Lady Stephanie Offline
#5 Posted : Tuesday, June 18, 2013 12:49:38 PM(UTC)
Lady Stephanie

Rank: Newbie

Groups: Registered
Joined: 6/18/2013(UTC)
Posts: 2

Was thanked: 1 time(s) in 1 post(s)
Today is my first attempt to make it into the Cricut Craft Room. CCR stated I needed to update my firmware, so I started following the onscreen instructions. My firmware update got stuck on Part One, the processing firmware just kept spinning like a barber shop pole.

I was not sure what to do and did not see any solutions that fit my situation. I decided to just close Cricut Craft Room. I did not turn my Cricut off. After closing CCR, I reopened CCR, and it opened normally. I stated I needed to update my firmware again, so I clicked to make that happen again, and it automatically started the firmware update at part two. Part Two took about 30 minutes but the progress bar kept proceeding and completed. Everything in CCR seems to be functional now and looks like the firmware updated. So, others might try exiting CCR,then re-entering, and maybe it will work for them too.

ladyaide1256fce40c Offline
#6 Posted : Sunday, June 23, 2013 10:13:37 PM(UTC)
ladyaide1256fce40c

Rank: Advanced Member

Groups: Registered
Joined: 11/9/2011(UTC)
Posts: 35

Was thanked: 3 time(s) in 2 post(s)
Be very quiet but wanted to let you know that you can use your cricut mats in the Silouhette. I still use my cricut but also love my Silouhette.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 1.029 seconds.
nebo-cricut-01