• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



JaimeG Offline
#1 Posted : Thursday, October 21, 2010 6:40:03 AM(UTC)

Rank: Member

Groups: Registered
Joined: 2/13/2009(UTC)
Posts: 17

Thanks: 2 times
Was thanked: 4 time(s) in 1 post(s)
I am hoping someone else has had this same problem and can lead me in the right direction;

I have tried to link the "Mini Monsters" cart I just purchased and it started to process, it asked me about accepting the terms and I selected agree...then before it could finish the final connection, the message came up something about making sure the cartridge was linked via the cord and it was. I tried a few times and each time it was the same. I also linked other carts this morning so I know that this is happening with only this cart. Can anyone help?

CricutingCarol Offline
#2 Posted : Monday, October 25, 2010 4:39:56 PM(UTC)

Rank: Advanced Member

Groups: Registered
Joined: 5/10/2010(UTC)
Posts: 33
Location: Jacksonville, Florida

Thanks: 3 times
Was thanked: 4 time(s) in 2 post(s)
I had this happen with my Paper Doll Dress Up cartridge last week. I was linking all my carts at once because I just got my G and with this one, it would recognize it, I would accept the terms and agree, it would start the connection and get about 80% of the way done and then either tell me to make sure it was connected OR would just kick it back to the start linking screen.

Here's what I read online and tried:
* Flip the cart around on the cord... sometimes it reads better that way.
* Turn off the G, wait, turn it back on and try it again.
* Link it through the Cricut machine (sometimes I guess it reads better that way).

None of those worked for me.... BUT I did get it to work....

by starting the process and then wiggling the cart on the cord! LOL! Seemed so silly, but it worked! I just wiggled it a little bit and kinda pushed gently to one side and suddenly, it finished the process of linking! I guess the connectors just needed a little help reading each other!

I also read a lot of people say that none of this worked for them and they had to contact PC and get a replacement cart. I sure hope you don't have to do this!

Good luck! Let me know if it works!!!!
Doxieluv01 Offline
#3 Posted : Monday, October 25, 2010 4:44:06 PM(UTC)

Rank: Advanced Member

Groups: Registered
Joined: 1/18/2007(UTC)
Posts: 9,716
Location: Sunny S. Florida

Thanks: 926 times
Was thanked: 2261 time(s) in 1788 post(s)
also try plugging your G into the power outlet and link the cart while your G is plugged in.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.268 seconds.