Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

ReesezPiecez Offline
#1 Posted : Friday, September 17, 2010 11:24:23 PM(UTC)
ReesezPiecez

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 7/25/2006(UTC)
Posts: 95
Location: AZ, Home of the SUNDEVILS!!

Thanks: 394 times
Was thanked: 19 time(s) in 19 post(s)
When I first powered on it asked for the cartridge to update. I inserted the cartridge, but it just kept switching between the two messages. Insert cartridge and do not power down. This went on for 30+ minutes. Now it's stuck on insert cartridge. The blade housing did not move either, upon turning on. I'm so bummed! I guess I will be calling Provocraft Monday morning. :( I wish I could reboot or something!! Any and all tips are welcome to fix this problem. LOL

Edited to add:

I just got off the phone with PC. There is something like a re-boot (hold down both buttons on top/bottom of menu button and the power button). This should prompt you to start calibration. Once that is done the screen to update should appear then insert your Nursery Tails cartridge and update. Unfortunately I am not at home to try this out on my machine. Hopefully this does the trick! WISH ME LUCK!! *crossing fingers*Unsure

Edited by user Monday, September 20, 2010 10:27:45 AM(UTC)  | Reason: Not specified

~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~ Offline
#2 Posted : Saturday, September 18, 2010 7:10:43 AM(UTC)
~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~

Rank: Advanced Member

Groups: Registered
Joined: 6/14/2008(UTC)
Posts: 287

Thanks: 155 times
Was thanked: 78 time(s) in 57 post(s)
Blink How unfortunate. I'm not an expert by any stretch but I know how frustrating a faulty product can be. I'm searching now for the reset button or a reset technique for the Imagine -- like we have on the Expression. If it were me I'd also drop PC an email or phone them with a description of the problem. You can also check the board and see if they monitor a help "thread" and post your question there. I'm thinking "reset" but that may not be the answer.
Good luck
I'll check this thread later to see if you've had any progress
Linda in Colorado
 1 user thanked ~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~ for this useful post.
ReesezPiecez on 9/20/2010(UTC)
*DebbyS* Offline
#3 Posted : Saturday, September 18, 2010 7:35:57 AM(UTC)
*DebbyS*

Rank: Advanced Member

Groups: Registered
Joined: 4/23/2009(UTC)
Posts: 661
United States
Location: Florida

Thanks: 361 times
Was thanked: 190 time(s) in 154 post(s)
This is probably a dumb question, but did you insert the correct cart? Nursery Tails? It took a long time for mine to update, but it finally did. I also had to callibrate twice because the cut was off, but seems fine after the 2nd callibration.

Sorry this happened to you and hope PC can rectify the problem soon.
 1 user thanked *DebbyS* for this useful post.
ReesezPiecez on 9/20/2010(UTC)
RoseannTurner Offline
#4 Posted : Saturday, September 18, 2010 5:44:27 PM(UTC)
RoseannTurner

Rank: Newbie

Groups: Registered
Joined: 3/24/2008(UTC)
Posts: 2

Was thanked: 2 time(s) in 2 post(s)
Mine is doing the same thing. At first it would not even readt the update, so I unplugged it and left it alone over night. When I tried this morning it said it was updating and had it in there for 3 and half hours.
Turned it off and now its back to not reading the uopdate. says to add the cart and its in there but wont read. Its sucks to get a new toy and not be able to play it.

Hope someone can help.
Thanks
Roseann
 1 user thanked RoseannTurner for this useful post.
ReesezPiecez on 9/20/2010(UTC)
ReesezPiecez Offline
#5 Posted : Saturday, September 18, 2010 8:58:15 PM(UTC)
ReesezPiecez

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 7/25/2006(UTC)
Posts: 95
Location: AZ, Home of the SUNDEVILS!!

Thanks: 394 times
Was thanked: 19 time(s) in 19 post(s)
*DebbyS* wrote:
This is probably a dumb question, but did you insert the correct cart? Nursery Tails? It took a long time for mine to update, but it finally did. I also had to callibrate twice because the cut was off, but seems fine after the 2nd callibration.

Sorry this happened to you and hope PC can rectify the problem soon.



LOL yes, I inserted Nursery Tails. Hopefully there's a solution that will be a quick fix rather than waiting for a replacement machine.
ReesezPiecez Offline
#6 Posted : Saturday, September 18, 2010 8:59:50 PM(UTC)
ReesezPiecez

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 7/25/2006(UTC)
Posts: 95
Location: AZ, Home of the SUNDEVILS!!

Thanks: 394 times
Was thanked: 19 time(s) in 19 post(s)
RoseannTurner wrote:
Mine is doing the same thing. At first it would not even readt the update, so I unplugged it and left it alone over night. When I tried this morning it said it was updating and had it in there for 3 and half hours.
Turned it off and now its back to not reading the uopdate. says to add the cart and its in there but wont read. Its sucks to get a new toy and not be able to play it.

Hope someone can help.
Thanks
Roseann



Looks like we are having the same issue. Mad Hopefully it's a quick fix!
~Army Wife Molly~ Offline
#7 Posted : Saturday, September 18, 2010 10:03:07 PM(UTC)
~Army Wife Molly~

Rank: Member

Groups: Registered
Joined: 8/13/2010(UTC)
Posts: 19

Was thanked: 8 time(s) in 7 post(s)
ReesezPiecez wrote:
When I first powered on it asked for the cartridge to update. I inserted the cartridge, but it just kept switching between the two messages. Insert cartridge and do not power down. This went on for 30+ minutes. Now it's stuck on insert cartridge. The blade housing did not move either, upon turning on. I'm so bummed! I guess I will be calling Provocraft Monday morning. :( I wish I could reboot or something!! Any and all tips are welcome to fix this problem. LOL



I received mine Thursday night and haven't been able to use it. My Nursery Tails cartridge is defective, therefore the firmware cannot be updated. I was able to get home in time to call PC before they closed yesterday (Fri) and they are sending me a new Nursery Tails. I am hoping that is the actual problem and I don't have to return a defective machine. :(
 1 user thanked ~Army Wife Molly~ for this useful post.
ReesezPiecez on 9/20/2010(UTC)
Junebuggy Offline
#8 Posted : Sunday, September 19, 2010 10:39:34 AM(UTC)
Junebuggy

Rank: Advanced Member

Groups: Registered
Joined: 4/13/2007(UTC)
Posts: 31
Location: Georgia

Thanks: 1 times
Was thanked: 5 time(s) in 5 post(s)
My Imagine makes a knocking noise when it goes from printing to cutting. It finally gets to cutting and is fine. Has anyone else had this issue? I am going to call PC in the morning. Despite this problem, I am really loving the Imagine.
 1 user thanked Junebuggy for this useful post.
ReesezPiecez on 9/20/2010(UTC)
Kathi.M Offline
#9 Posted : Sunday, September 19, 2010 12:09:36 PM(UTC)
Kathi.M

Rank: Newbie

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 9/15/2010(UTC)
Posts: 8
Location: Orlando, FL

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
I got my new Cricut Imagine Friday and it does not work. I hope Provo Craft can get it to work for me or send me another one. HSN says they are back ordered for a while. They can’t fill the orders they have. I can’t get the cutter/print housing to come out from its hiding place on the right side of the machine. When I turn it on it makes a very load grinding noise. Did anyone else have a problem?
 1 user thanked Kathi.M for this useful post.
ReesezPiecez on 9/20/2010(UTC)
CarolS Offline
#10 Posted : Sunday, September 19, 2010 12:16:20 PM(UTC)
CarolS

Rank: Advanced Member

Groups: Registered
Joined: 8/21/2009(UTC)
Posts: 341
United States
Location: SE Coastal Georgia

Thanks: 16 times
Was thanked: 102 time(s) in 50 post(s)
Good Lord mine is suppose to be here tomorrow. Sure hope I don't have the issues y'all are having.

You were aware that you DO HAVE to calibrate the machine before using it.

Saw a video the other night about it online which I got from one of the cricut groups on yahoo groups but can't remember which one it was now.

Y'll may want to do a search on line "calibrate Cricut Imagine" to see if you can find it.
 1 user thanked CarolS for this useful post.
ReesezPiecez on 9/20/2010(UTC)
CarolS Offline
#11 Posted : Sunday, September 19, 2010 12:19:11 PM(UTC)
CarolS

Rank: Advanced Member

Groups: Registered
Joined: 8/21/2009(UTC)
Posts: 341
United States
Location: SE Coastal Georgia

Thanks: 16 times
Was thanked: 102 time(s) in 50 post(s)
Don't remember the one I watched for calibrating the Imagine before using it but here is what google brought up....

http://www.google.com/#h...&fp=6f32b8af52b7e0b8
 1 user thanked CarolS for this useful post.
ReesezPiecez on 9/20/2010(UTC)
ReneJones Offline
#12 Posted : Sunday, September 19, 2010 12:38:48 PM(UTC)
ReneJones

Rank: Member

Groups: Registered
Joined: 4/26/2008(UTC)
Posts: 11

Was thanked: 3 time(s) in 3 post(s)
I got mine on Thursday... works great BUT, it won't hook up with my GYPSY!Confused I took mine to a SWARM on Saturday thinking I can use it with my GYPSY and worked back and forth for about 2 hours trying to figure out what I was doing wrong.. borrowed other people's cords and everything to see if it was something I was doing wrong or if it was my cords... now I am hearing that other people are having the same problems?
 1 user thanked ReneJones for this useful post.
ReesezPiecez on 9/20/2010(UTC)
GloriaContreras3 Offline
#13 Posted : Sunday, September 19, 2010 1:33:43 PM(UTC)
GloriaContreras3

Rank: Advanced Member

Groups: Registered
Joined: 10/14/2009(UTC)
Posts: 300
Location: Salinas CA

Thanks: 69 times
Was thanked: 27 time(s) in 23 post(s)
The gypsy will be compatible with the Imagine once the Update comes out I believe next month.
 1 user thanked GloriaContreras3 for this useful post.
ReesezPiecez on 9/20/2010(UTC)
KellBell72 Offline
#14 Posted : Sunday, September 19, 2010 1:37:36 PM(UTC)
KellBell72

Rank: Advanced Member

Groups: Registered
Joined: 8/7/2006(UTC)
Posts: 116
Location: Ohio

Thanks: 8 times
Was thanked: 18 time(s) in 16 post(s)
Mine is due to arrive tomorrow as well and I hope I don't have any issues.
 1 user thanked KellBell72 for this useful post.
ReesezPiecez on 9/20/2010(UTC)
thescrapmaster Offline
#15 Posted : Sunday, September 19, 2010 1:43:54 PM(UTC)
thescrapmaster

Rank: Advanced Member

Groups: Registered
Joined: 3/15/2008(UTC)
Posts: 2,247
Location: Tennessee

Thanks: 849 times
Was thanked: 803 time(s) in 366 post(s)
Oh NO!! I really hope that they can get it figured out for you quick!! The update took a LONG time to get done though.
 1 user thanked thescrapmaster for this useful post.
ReesezPiecez on 9/20/2010(UTC)
mmturc Offline
#16 Posted : Sunday, September 19, 2010 1:46:46 PM(UTC)
mmturc

Rank: Advanced Member

Groups: Registered
Joined: 3/21/2008(UTC)
Posts: 61
Location: S.C.

Thanks: 6 times
Was thanked: 4 time(s) in 3 post(s)
Now I don't know if I am excited to get mine or scared. Sure hope the instructional dvd is good. That is one area where PC seems to be lacking. Good luck with your machines. If mine doesn't work well it will be going back. Thank goodness HSN has 30 policy, might need it.
 1 user thanked mmturc for this useful post.
ReesezPiecez on 9/20/2010(UTC)
~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~ Offline
#17 Posted : Sunday, September 19, 2010 2:32:08 PM(UTC)
~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~

Rank: Advanced Member

Groups: Registered
Joined: 6/14/2008(UTC)
Posts: 287

Thanks: 155 times
Was thanked: 78 time(s) in 57 post(s)
Ooook! I am sufficiently freaked out now. I got mine 2 days after the debut and I just let it sit until my plan to start her up today. I've been planning to try it out since I got up this morning. After reading these posts, and having gone through Gypsy-Hell last year, I think I should run this thing through its paces ASAP in case I have to put it back into the mail to HSN. Hopefully, it's good.

Scared
 1 user thanked ~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~ for this useful post.
ReesezPiecez on 9/20/2010(UTC)
~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~ Offline
#18 Posted : Sunday, September 19, 2010 2:51:03 PM(UTC)
~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~

Rank: Advanced Member

Groups: Registered
Joined: 6/14/2008(UTC)
Posts: 287

Thanks: 155 times
Was thanked: 78 time(s) in 57 post(s)
It worked -- Yea! Woot It was a bit confusing in that both the booklet and the DVD say that the Imagine That cartridge should be inserted at the update prompt. But, as someone pointed out in the group and according to a lone yellow insert in the box shipped to me, it is the Nursery Tails Cart that should be inserted. When I inserted the Imagine That Cart, nothing happened as the DVD stated it should. It continued to show the prompt for inserting the "Imagine That" Cart. I didn't power it down -- as it at some point warned me that doing so at the wrong time could "permanantly damage the machine" (sigh).
I just took the Imagine That Cart out and put the Nursery Tails Cart in. It took a couple minutes to recognize it and then about 10 minutes to update. I've printed and cut two small things from Nursery Tails -- now I'm off to try out the other carts! Yea!
For those who had troubles, I hope that your fixes are quick and easy and don't involve returning your new toy.

Happy Scrappin!

 1 user thanked ~~L*I*N*D*A ^I~N^ C*O*L*O*R*A*D*O~~ for this useful post.
ReesezPiecez on 9/20/2010(UTC)
KimberlyEverhart Offline
#19 Posted : Sunday, September 19, 2010 3:24:54 PM(UTC)
KimberlyEverhart

Rank: Advanced Member

Groups: Registered
Joined: 1/19/2008(UTC)
Posts: 75
Location: USA

Thanks: 11 times
Was thanked: 15 time(s) in 15 post(s)
I am expecting mine tomorrow. I sure hope that I do not encounter any of these issues. I hope all of you are able to spend your time creating rather than dealing with figuring out the machine. Crossing my fingers for a good one! Good luck, ladies.
 1 user thanked KimberlyEverhart for this useful post.
ReesezPiecez on 9/20/2010(UTC)
EsmeraldaTwinsMom Offline
#20 Posted : Sunday, September 19, 2010 3:38:44 PM(UTC)
EsmeraldaTwinsMom

Rank: Advanced Member

Groups: Registered
Joined: 5/16/2007(UTC)
Posts: 93
Location: California

Thanks: 17 times
Was thanked: 16 time(s) in 15 post(s)
So sorry I hope you get it fix soon!!
Mine is not here yet :(
 2 users thanked EsmeraldaTwinsMom for this useful post.
Kathi.M on 9/19/2010(UTC), ReesezPiecez on 9/20/2010(UTC)
scrapncathy Offline
#21 Posted : Sunday, September 19, 2010 5:21:12 PM(UTC)
scrapncathy

Rank: Advanced Member

Groups: Registered
Joined: 4/12/2007(UTC)
Posts: 148
Location: Northern CA.

Thanks: 14 times
Was thanked: 31 time(s) in 21 post(s)
Gosh you girls are making me nervus on getting my machine! I am hoping it will come tomorrow. Sounds like you need a day to get it going? By the time you watch the video, read the booklet, calibrate, etc.....sounds exhausting!
BigGrin

Still excited!
 1 user thanked scrapncathy for this useful post.
ReesezPiecez on 9/20/2010(UTC)
Junebuggy Offline
#22 Posted : Monday, September 20, 2010 9:30:47 AM(UTC)
Junebuggy

Rank: Advanced Member

Groups: Registered
Joined: 4/13/2007(UTC)
Posts: 31
Location: Georgia

Thanks: 1 times
Was thanked: 5 time(s) in 5 post(s)
I have talked to PC this morning and she listened to the noise. They said there is a problem in the motor and will send me a new machine.
 1 user thanked Junebuggy for this useful post.
ReesezPiecez on 9/20/2010(UTC)
BugginAway Offline
#23 Posted : Monday, September 20, 2010 11:52:33 AM(UTC)
BugginAway

Rank: Advanced Member

Groups: Registered
Joined: 1/7/2009(UTC)
Posts: 311

Thanks: 72 times
Was thanked: 81 time(s) in 48 post(s)
Mine was JUST delivered and I'm so glad I read this post before upwrapping everything and putting in the wrong cart! I would be in a tizzy trying to figure out what was wrong. I'm keeping my fingers crossed that everything hooks up and goes okay. BUT if not I've had to return/replace two Expressions before as alot of did at one point I think and PC was really great about getting them to me quickly. I "imagine" since the machine is already on backorder it may take awhile to get one if I do have to return it, but for now, we are just thinking positive! BigGrin
KellBell72 Offline
#24 Posted : Monday, September 20, 2010 12:17:40 PM(UTC)
KellBell72

Rank: Advanced Member

Groups: Registered
Joined: 8/7/2006(UTC)
Posts: 116
Location: Ohio

Thanks: 8 times
Was thanked: 18 time(s) in 16 post(s)
I got mine about an hour ago. It's all set up and seems to be working fine! I can't WAIT to get some more time to play this coming weekend.
ShawnaWebster Offline
#25 Posted : Monday, September 20, 2010 12:34:25 PM(UTC)
ShawnaWebster

Rank: Advanced Member

Groups: Registered
Joined: 5/4/2009(UTC)
Posts: 34

Was thanked: 4 time(s) in 3 post(s)
So here is my problem if someone can help. I put my mat in to calibrate. It prints and then send the mat back through and does not cut or ask me for a number. It goes back to the normal menu screen and does nothing.
cricutkris Offline
#26 Posted : Monday, September 20, 2010 3:58:20 PM(UTC)
cricutkris

Rank: Advanced Member

Groups: Registered
Joined: 2/25/2009(UTC)
Posts: 1,052
Location: PA

Thanks: 95 times
Was thanked: 448 time(s) in 225 post(s)
ShawnaWebster wrote:
So here is my problem if someone can help. I put my mat in to calibrate. It prints and then send the mat back through and does not cut or ask me for a number. It goes back to the normal menu screen and does nothing.


My sister in law is having this problem too. Mine works fine. Does anyone know why this happens?
ShawnaWebster Offline
#27 Posted : Monday, September 20, 2010 4:41:10 PM(UTC)
ShawnaWebster

Rank: Advanced Member

Groups: Registered
Joined: 5/4/2009(UTC)
Posts: 34

Was thanked: 4 time(s) in 3 post(s)
i ended up getting through to Provo Craft finally and they sent me a label to return it and will be replacing it. they said it is defective so if you are having this problem too definitely give them a call.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 2.032 seconds.
nebo-cricut-01