Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

ames724 Offline
#1 Posted : Thursday, January 30, 2014 2:51:07 PM(UTC)
ames724

Rank: Newbie

Groups: Registered
Joined: 1/27/2014(UTC)
Posts: 2

I've never posted here before but I'm going out of my mind searching online and have been working with PC customer service for a week or two no to no avail. I was hoping someone here may be able to help. So here goes...

My sister and I received cricut expressions Christmas 2009.(I believe our parents bought them at WalMart - they are black.) We both have several cartridges and have been cutting away. We haven't bought any recently (busy having babies :)) but each got a few around christmas time a few months ago. However, we found that when we put in any of the new cartridges in our machine the machine gives us a "Cartridge Comm Error". We are both having the same problem, with different, new cartridges. We each have about 3 different ones that won't work. PC said we needed to update our firmware. We hadn't done that before so both tried. The updates say they're successful but the machine still will not read the cartridges. I must have tried updating a dozen or more times in various ways, turning off anti-virus and firewall, using different usb cords, usb ports, I've used windows xp, windows 7, windows 8.1, uninstalling and reinstalling software... The firmware updates to 2.43 and the computer says it's successful but the machine will still not read these cartridges?! I'm so upset....I want to use my machine. I'm looking at buying a new one but why should I have to? I just want to fix what I have and go back to the trouble free cricut I've always had. :( After the past few updates I did, the machine now sometimes says "George and Basic Shapes Loaded" and then flashes over to "Cartridge Comm Error". Does anyone have any more ideas? Anyway, I'm assuming this is a firmware problem, maybe I'm missing the boat and it's something else entirely? Any help would be greatly appreciated!!! Thanks in advance.

(I hope I'm ok posting this, I see so many other firmware posts but have read through them and tried everything I read to no avail so I decided to just post a new thread. Thanks!)

ETA: This may be helpful information? But I can cut from CCR to my cricut no problem.

ETA: When I do the update in CCR it seems to skip step 3 - it doesn't have me restart in update mode and those all turn green and it says it's completed successfully.

Edited by user Friday, January 31, 2014 7:18:36 AM(UTC)  | Reason: Not specified

lrozlogcbb1f972 Offline
#2 Posted : Saturday, February 01, 2014 3:05:40 PM(UTC)
lrozlogcbb1f972

Rank: Newbie

Groups: Registered
Joined: 1/2/2013(UTC)
Posts: 1

Same EXACT thing is happening to me too. I have 2.43 and it will work with CCR and old cartridges but it stalls on new cartridges and says cartridge comm error. I need my Cricut back! I hope we can get a resolution!

Leigh
Cuttingedge Offline
#3 Posted : Saturday, February 01, 2014 4:54:52 PM(UTC)
Cuttingedge

Rank: Member

Groups: Registered
Joined: 12/26/2008(UTC)
Posts: 10
Location: Illinois & Florida

Thanks: 2 times
Was thanked: 3 time(s) in 3 post(s)
I had the same problem after not using my machine for a few month. Customer service can walk you through the updates. Your firewall may also be blocking the CC. bridge. Call Cricut. You'll wait a while but once you get through to rep, they will stay with you until your problem is solved
ames724 Offline
#4 Posted : Wednesday, February 05, 2014 9:37:49 AM(UTC)
ames724

Rank: Newbie

Groups: Registered
Joined: 1/27/2014(UTC)
Posts: 2

Well, it's nice to know I'm not going crazy. :) unfortunately, I've reviewed my problem with customer service and they say it's just not taking the update but don't have an answer on how to fix it. I've turned off the firewall, anti virus, etc and nothing's fixed it. :( I want me cricut back too! :(
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.520 seconds.
nebo-cricut-03