Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

craftynanna Offline
#1 Posted : Sunday, November 03, 2013 4:00:01 PM(UTC)
craftynanna

Rank: Newbie

Groups: Registered
Joined: 4/5/2011(UTC)
Posts: 9

I have just updated the firmware and downloaded the drivers and so on for my circuit, I have not used it for a while . everything went ok and it synced it and all, but when I go to cut in CCR its says no usable devices found what am I doing wrong?

chris xx
Cricut Dani Offline
#2 Posted : Sunday, November 03, 2013 7:00:29 PM(UTC)
Cricut Dani

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member, Circle Moderator, Cricut Community Moderator
Joined: 12/5/2011(UTC)
Posts: 66

Thanks: 17 times
Was thanked: 21 time(s) in 15 post(s)
Originally Posted by: craftynanna Go to Quoted Post
I have just updated the firmware and downloaded the drivers and so on for my circuit, I have not used it for a while . everything went ok and it synced it and all, but when I go to cut in CCR its says no usable devices found what am I doing wrong?

chris xx


Hello Chris,

Have you tried reinstalling the Craft Room drivers through the help link in the top left hand corner of the program or another USB port on your computer? If you are still experiencing issues after trying the steps above please call Customer Support at 1-877-7CRICUT M-F 7am-6pm MST.

-Cricut Dani
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.174 seconds.
nebo-cricut-02