Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

papelografodigital02acfaf4 Offline
#1 Posted : Monday, July 15, 2013 5:18:56 PM(UTC)
papelografodigital02acfaf4

Rank: Newbie

Groups: Registered
Joined: 7/15/2013(UTC)
Posts: 1

Hi I just bought a Cricut Mini and followed the installation steps closely. But when I try to cut the blade does not even touch the paper. I have gone through every installation step and there's nothing different with what I've done. What can I do? I ordered it through and cannot return it because I'm not in the US, so I'd be dead thankful fot a solution to this mess.
Kiethann Offline
#2 Posted : Monday, July 15, 2013 5:55:31 PM(UTC)
Kiethann

Rank: Advanced Member

Groups: Registered
Joined: 4/14/2009(UTC)
Posts: 775
United States
Location: master questionair page 16 post 465

Thanks: 99 times
Was thanked: 452 time(s) in 339 post(s)
you might want to double check how you have the needle housing installed. sometimes it will slip when you fasten the screw. also double check where you have the pressure set at. You might also remove the needle and reinsert it. good luck. if none of these work be sure and call the cricut support line.
TammyPuckett Offline
#3 Posted : Monday, July 15, 2013 6:53:36 PM(UTC)
TammyPuckett

Rank: Advanced Member

Groups: Registered
Joined: 1/3/2010(UTC)
Posts: 798

Thanks: 132 times
Was thanked: 319 time(s) in 181 post(s)
Make sure your blade housing in loaded properly & that your blade setting is correct!
JoyceG Offline
#4 Posted : Monday, July 15, 2013 8:21:31 PM(UTC)
JoyceG

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 3/17/2007(UTC)
Posts: 1,716

Thanks: 1280 times
Was thanked: 883 time(s) in 576 post(s)
I had this problem when I bought my first expression. It cut for one day and then the blade stopped going down to cut. I tried everything to get it to cut again but nothing helped. I ended up finding the problem but couldn't fix it since I don't have any electronic welding/sottering tools. I had taken the cover off the gray box that holds the cutting blade housing unit and moves across the machine. I saw that a wire had broken off so the blade wasn't getting a full connection that would make it move down to cut. I had bought the machine at walmarts and returned it the next day for a differnt machine. That was 2 years ago and no problems since. *knock on wood**

Joyce
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.245 seconds.
nebo-cricut-03